Anti Torque Pedals

I’ve been flying the Bell for a few months now and it’s by far the best helicopter in MSFS. I have noticed an issue with the ATP’s going back to the neutral position on there own. I can fix this by moving the pedals around for a second and they start responding again. I don’t have this issue with any other game I play with my pedals.

Mine are the Thrustmaster TFRP Flight Rudder Pedals.

Hi David.

What axis do you have your rudder pedals mapped to and have you checked that there are no other of your controls mapped to one of the rudder commands, like an XBOX controller for example?

It’s probably not an issue with ghost mappings, but best to count it out first.



It’s mapped to Joystick Slider Y. The closest thing to that is Joystick Slider X which in the pinky wheel on my controller. I use that to control the power input.

Another thing to check is that you don’t have any of the Assistance options enabled, as the virtual co-pilot might be working against you on the movement of the pedals.

No assistance enabled at all. I’ll try messing with the control scheme a bit and see if that does anything.