Any idea why I got no dust particles for the B206?

With the B206 I dind’t get dust particles, with the B47G it worked.
Checked Heli-Manager Settings, deleted the Caches, etc. but didn’t get the particles on the B206.

Only switch from B47 to B206 and no dust

@RotorRick found the BUG. In the PerFrameCode.txt file the particles are calculated with A:GENERAL ENG THROTTLE LEVER POSITION:1 in my case I use the Collective Axis in FSUIPC and this gives the observed problem :slight_smile:
I changed the code like this L:Aircraft.Input.Collective.Position, now it works. Scaled the value down by 100 guess the throttle is 0…1 and the Collective is already 0…100
Same change will be necessary for B47G

Here the two code parts:

4.0 (A:RADIO HEIGHT, meters) - 0.0 max 0.2 *
(L:Aircraft.Input.Collective.Position, number) 50.0 - 0.0 max 0.1 * *
(A:AIRSPEED INDICATED, knots) 0.05 * -
100.0 * 100.0 min 0.0 max
(>L:NewSwirlStrength, number)
(L:Aircraft.Input.Collective.Position, number) 0.0 max 5.0 (A:SURFACE TYPE, number) 2 == * +
(A:RADIO HEIGHT, meters) 5.0 * -
0.0 max 100.0 min
(>L:NewParticleStrength, number)

The scale down also gives me only light dust effects, similar tot the B47G ones.

in_04, very nice find, totally points the team in the right direction! We’ll get this fixed for the next build.


do any of you know how to change the color of the particle effects ? I find them way too red. those of B206 Cowansim are much more realistic