B47 no takeoff possible with governor engaged

Hello, Friday I bought the B-47G for MSFS 2020.I already had the Bell 206.

When using the B-47G with governor engaged I cannot lift off. It‘s just impossible.

RPM needle is in the green range Manifold Pressure goes no further than 19 with max collective. See screenshot:

I only can taxi with a noise when the skids scratch the tarmac but there is no liftoff possible.

I can only fly the machine with governor off and a separate axis for the throttle.

For both Flyinside helicopters I use the Logitech throttle quadrant for the collective function with the same profile in MSFS with reactivity set to 100% and the other settings at 0% and full range of motion. It works flawlessly for the 206.

I saw in videos on Youtube that the manifold pressure can go clearly beyond 19 and that the B-47 can take off quite fast with governor engaged. I’ll put a screenshot below from a video by Skaska S. where he is demonstrating a takeoff with active governor.

I tried this starting the flights with running machine from the active runway.

Is there anything that I am missing?


Here is the screenshot from the video by Skaska S. showing a manifold pressure of 30 shortly during takeoff:

You likely have the wrong axis setup and/or double bound to something.

Look at your bindings and match what they should be in the manual.

Join the discord, I am sure someone there can help you.


Axis setup is correct. When I end the flight and just switch to the Bell 206 with the same setup I can fly it without problems. As I said, when I just add the rotor axis to one of the logitech throttle levers and disengage the the governor it works as well.

Try reinstall the 47… You are the only person reporting this, so it’s likely an issue with your setup.

You do understand there is a THROTTLE axis for the engine and a COLLECTIVE axis for collective pit on the rotor, right? They are VERY different


Thank you Rick. I definitely understand what I have to do. Simply look again at my last post, when I just switch to the 206 with EVERYTHING else in exactly the same state it works flawlessly. I slowly raise the collective and the 206 lifts off as it should but NOT the 47, here the manifold presssure rises to 19 and I can hover over the ground a bit, that’s it. When using two different axis for collective and throttle, though, I can fly the 47 without govener engaged as is done in the original helicopter.

Hello, I found the solution! Flying the 206 I recognized that the max torque was quite low as well with full collective although flying was possible.

I looked closer to the heli manager and raised the physical stick travel, it was about 70%. I raised it and „Bingo“, now torque goes higher and I can fly the B47 with governor, although it is quite fun to do it without it all manually!:blush:

Most Excellent. I knew it was an AXIS issue!

Great diagnostic work!


I’m getting the same issue, with governor on changed the physical stick travel settings on heli manager…no joy
Worked a few days ago, but no longer
All works fine with governor off

I’ve checked bindings…no double mappings

Further Testing
Governor on…nothing
Governor off…everything appears to be correct, cyclic works, throttle works…but no lift. I can get a few feet off the ground and that’s it
Was fine before the carribean update

I still have to install the carribean update. I will check if it has changed the B47 behaviour for me as well and come back.

Looks like this conversation has moved to the discord server :slight_smile:

1 Like