Bell 206 - Excluding HeliManager in Windows Defender improves control responsiveness?

I’m posting this in hopes that some other people can try it and report their findings, because this seems to have made a big difference to control responsiveness, particularly in low IGE hover for me.

In Windows, go to Start > Settings > Update & Security > Windows Security > Virus & threat protection

Under “Virus & threat protection settings” click “Manage Settings”

Scroll down and find “Add or remove exclusions”

I added both the FlyInside Heli Manager folder and the FIHeliManager2.exe process as exclusions.


Now launch Heli Manager and MSFS and go flying. Specifically, try picking up into a low IGE hover.

Without the exclusions I find myself drifting around a lot more than I’d like and getting into PIO more easily than I would expect. I actually ended up raising the stability from 5 to 10 to help with that.

With the exclusions in place I’m able to pick up into a stable hover without issue at the default “Realistic” settings.

It’s very possible this is placebo, but I went back and forth a few times and could always immediately tell the difference. It’s also possible it’s something else on my system and won’t work for you, but if there’s something to it maybe it’s worth investigating.

To be clear, I am not suggesting that Antivirus exclusions are a good thing, nor would this be considered a permanent solution. But if antivirus is interfering with the app maybe there’s something FlyInside can change so that this exclusion isn’t necessary.

1 Like

I don’t know if it’s a placebo effect or if my skill levels just shot up a notch. Taxiing seemed a bit more ‘amenable’. We’ll see.