Bell 47 a taildragger?

I must have missed something on the setup, and would sure like to know what it was.

Using Easy Mode, as collective is raised the helicopter rocks backward and the tail strikes the ground. It’s as if I have a 500 lb gorilla riding on the tail. In an attempt to pre-empt this behavior, I start with the cyclic full forward and raise the collective. The helicopter still rocks backward, not forward, what am I missing?


Okay, found the problem, please disregard. I copied a Throttle (Collective) Profile that used a wheel on the side of the throttle for pitch trim, which was rolled all the way nose up. Neutralizing the control has solved the issue. I will be removing that assignment. Since the helicopter has no pitch control, would it be better for it to ignore any pitch trim settings??

I want to thank myself for the prompt response.

Happy Rotoring,


1 Like

:joy: Hi mate and welcome !! I am glad you posted and reposted the solution for yourself and we aim to please, well done sir LOL

Seriously though, thanks for sharing, could help someone else in the future, cheers Paul.



Thanks for the warm welcome. I have also noticed that when MSFS2020 loads it seems to default the elevator trim to a Takeoff setting, which is one unit, nose up. This still makes the helicopter want to back up with cyclic neutral and requires constant pressure in forward flight. I have found that if I leave a couple of buttons assigned to Nose Up and Nose Down trim, I can control this on each load. All it takes is to switch to the External Camera, where you can see your elevator trim displayed with the instrument overlay. If I hold the Nose Down button until the trim shows 0 and is centered on the index, the helicopter is MUCH easier to fly, if you can call it that!

As I mentioned above, perhaps this model should not consider the pitch trim variable and assume a constant of 0? Just a perhaps.


Wow. That explains a lot. I have had several sessions with some forward or reverse bias. I thought it was just me.
Now I have verified that the trim wheel affects my hover stability. Good to know.

EDIT: I revisited the spreadsheet and found that #14 “Trim System” was implemented. Not sure when. That accounts for this new functionality. I’ll need to experiment with it during flight AND see how difficult it is to get back to nice hover.

I think it was added for folks with a spring-centering joystick, which is probably more common. Maybe if the heli manager app had a checkbox “My joystick spring-centers, please enable trim”, that would be nice

The spring on my control is very heavy. For the first time, today I tried trimming my short flight around Las Vegas.

While there are too many interactions to trim to a specific air speed, it did feel somewhat easier to maintain any given speed, basically just taking the weight off.

Approaching Nellis AFB I had to gradually unwind my pitch to get the speed down and I successfully got it (blindly) back to zero pitch in hover.

Having this functionality will encourage me to take some longish flights. But I won’t be using on short hops.

1 Like