Bell 47 in X-Plane questions

Hi Fly-Inside,

installed it just yesterday and I’m impressed. The manual throttling is quite the challenge; much more work than in the S300 with it’s correlator. Handling is smooth and a little laggy as expected. I have a few questions though.

  1. Experimental Flight model on/off or doesn’t matter?

  2. I’m experiencing little to no ground effect. I can set it down where I want it, but the last meter or so it just drops like a stone.

  3. Cold & Dark has the helicopter light up like a christmas tree, even with battery off

  4. Serious Power issues: When lifting off I’m on max manifold P; no matter if governor on or on maual. Also I can’t seem to climb without overloading the engine. Highest altitude was 150 feet. No translational lift seems to kick in.

  5. Sometimes when in governor mode the ignition key switch dances around and the engine quits even with all the ts and ps in the green

Maybe I’m doing something wrong here?

Using full sized controls, Field altitude of Test-Flight 800 ft (KVNY) and 15 degrees, Altimeter 3004.

Plug-Ins I use:
Mission X
Fly With LUA
Axis Viewer

Thanks Simon

Hi simon and welcome mate :slight_smile:

We have our own Flight model, don’t need Experimental.

Ground effect is there but not strong, little more cushioning of the collective and that should help you on touchdown.

I don’t see flashing lights on start up, all cold and dark as should be…any key bindings or controllers double mapped ?

What are you using as a collective here ? She needs finesse on all power settings.

I believe you can get some one on one with our Flight modelling bod if you are looking to improve your skills ? :slight_smile:

Any more help please ask.


edit* we are looking at the dancing switches.

Hi Tony,

thanks for your replay. 1. & 2. checked off the list.

I am using a Bell206 Replica Collective with twist throttle as well as a UH-1/B407 Cyclic. I have checked Key bindings. Only thing I control via Buttons are: Starter, Landing lights on/off Push To Talk, and Pause.

Made a short video of my shortest flight ever. It’s crashing with Manifold P and RPM in the green. That can’t be right?

I tried to deactivate most of my plugins. Still no joy.



Ouch mate !!!

That video is unexpected/abnormal but we are trying to reproduce it? Shoot Dan an email so he can setup a debugging session with you to help/try to get to the bottom of what’s going on fella.


Hey Tony,

will drop him a mail. I found out now that it probably has to do with the twist grip: When on automatic governor with the throttle assigned to my twist grip axis it crashes immediately after lift off. However as I unassigned the throttle axis it worked. It also works with throttle assigned to the twist grip when on manual mode. Climb is painfully slow though.

My controls are from OE-XAM (
Never had problems so far.

Cheers and a happy holiday

1 Like