Collective binding to throttle not working after last sim update

MSFS (bought through Steam) has made a small update today. My collective (Virpil rotor base) is still bound to throttle in the sim and is working fine as I can check in control options, or by loading another aircraft. But it does not control Bell 47g’s collective anymore. All other controls seem fine.
Any idea?
(B 47 purchached through Flyinside website)

Maybe check that the update hasn’t somehow mapped the control of the virtual collective to any of your other physical controls/axes.

In other words, your physical collective might still be mapped to the virtual one, but another binding is preventing it from moving.

Check other controllers, including any connected xbox controller, for any double mappings to the virtual collective.

I can confirm the problem: the collective is not responding although correctly bounded to thottle. I have double cheched that no other controllers are bound to throttle.

Steam MSFS and in-game purchase of Bell 47.

Great helo, BTW. Coming from DCS helos, all I can say is this one is great.

Hi Achab and zal,

Dan, the friendly dev, has just let me know that a B47G update has just been issued and alongside the latest MSFS “hotfix” update, should return your collective to a working state.

Cheers

Paul

Edit: If you are using the Marketplace version and if the update has yet to be posted, then the work-around is to bind your physical axis to the ‘Throttle 1’ axis.

1 Like

Thanks Paul,
Work-around working as intended. I had to unbind the throttle axis (and bind the throttle 1 axis).
Great helo and great support, indeed!

1 Like

It’s good to have you aboard and to hear that you are enjoying the Bell.

1 Like

Thanks! It’s working again. Perfect!

1 Like

Got Bell update version 1.47.0 today for Steam. Still can’t get it off the ground. When I get a chance I’ll restart the computer in the unlikely chance it might help.
The throttle setting for propller is the default MSFS slider assignment for my Thrustmaster airbus joystick. Am I missing something?

Hi Paul.

The following instructions are on the download page on the FlyInside website and if you haven’t seen them on Steam, they should still be relevant.

"Q: How do I setup my helicopter controls in MSFS?

  1. Bind the MSFS aileron and elevator axes for cyclic control.
  2. Bind the MSFS rudder axis for anti-torque/pedal control.
  3. Bind the MSFS throttle axis for your helicopter collective control.
  4. If you have a full helicopter collective with twist-throttle, bind the twist-throttle to MSFS’s Propeller Pitch Axis 1 axis. You can turn off the default piston engine governor from FlyInside Heli Manager’s Flight Model tab.
  5. Set the MSFS Sensitivty for each axis to 0%, and the reactivity to 100%."

Please check that your bindings are set as above and let us know if you still have an issue.

Cheers

Paul

My downfall was not paying enough attention to sensitivty sliders, just assumed leftmost position was 0. All is well now.
Thanks.

1 Like

change Throttle to “Throttle 1 Axis (1to 100)”

1 Like

I was having same issue , ran the update from Market place. rebooted , Boom worked well,
I was doing ( or attempting) a few RTT ( return to target ) with some quick stops. little bit of a handfull, overall pretty close , if i had the separate throttle it would be great as i used the throttle to help bring aircraft around with cylic and leave collective set for the run. when i was spraying in the 47 ,having a ball ! 1200 hours in a 47G

1 Like