Collective way too sensitive

The collective is so sensitive, even when fully loaded it takes off like a coiled spring. I’ve got the Puma X controls and have another friend with the Bell 206 and Max Flight Stick setup and we both have the same issues where it feels so sensitive in lifting off the ground or trying to gently land. Very small inputs have a massive jump on Torque that seems ridiculously inaccurate. We have tried many adjustments in the sim and Heli Manager but can’t get the collective to behave regardless of what inputs we have adjusted.


I have the same problem. I use Virpil Controls

1 Like

$60au down the drain and back to DCS I go :man_facepalming:

It’s fairly obvious there is some kind of joystick issue. If there wasn’t MANY more people would be having an issue. I would check you calibration, any additional joystick software installed by the manufacturer or third part, the curves in MSFS and finally the setting in HeliManager.

If you need additional assistance, there is always our Discord where lots of people hang out including the devs that can work through your issue.


Hi Rick, not wanting to sound condescending, but I’ve been flying sims for more than 20 years with professionally made heli sim controls. For more than 30 years I fly in real helicopters for a living, Bell 206/Longranger, AS350B2/3, AS355 F1, Bell 412. I’ve also worked with several Rescue companies with their sim setups for various training purposes. So I know about setups, calibrations, software editing, cfg editing, various settings in different software with what conflicts with what, but still I’ve almost given up.

I’m sorry but four other people I work with who are a lot more technically minded than me In Avionics and Engineering and have tried this with their own setups (as we play multiplayer) and all have the same issues. We normally don’t frequent forums as we find it easier to solve things ourselves, but one of our group who writes software for helicopter waterbombing aircraft said it could be anti virus software preventing Helimanager from running properly, but I have tried that and it all seems fine to me, or it can be just plain conflicts in all the different software that make the Collective too sensitive and virtually unresponsive to curve, calibration or setup adjustments.

Anyhoo we’ve all going back to our full time jobs after our break - but I will try discord. I’m sure sure someone will find a solution soon. Thanks!