Failure to accept throttle inputs now . .


I have been using the Bell 47 since you released it and enjoying it a lot, especially for scenery reviews. Recently, I used it to fly into the new LAPD Hooper Helipad scenery.

Today, I loaded the helicopter up and started her up at Hamilton Island with a view to a short flight out to Reef World, the Great Barrier Reef in Australia.

Helicopter starts up, but now, no matter what I do, I get NO throttle or power at all! I have a Logitech Extreme 3D Pro that I use to fly her with (all controls work fine), Logitech rudder pedals (again, all work fine) and I have mapped the centre level of my Saitek Throttle Quad for the Throttle Axis in MSFS.

I have checked and double-checked the throttle and no changes have been made. All is well inside the CONTROLS section of MSFS - but moving the lever to power her up and attempt to lift off, results in nothing!

It’s all going pear shaped and I’m doing my head in trying to find out what’s going on here . . .! I only flew her last week for the Hooper LAPD Helipad review!

I have exited the simulator and reloaded it - still no power when moving the lever. Engine is running fine.

Any help would be appreciated.


P.S. - any more news on the FLOAT version of the helicopter?


Looks like I found the issue . . .

In MSFS, you have to set up different control profiles when you use more than one type of aircraft. All was well when I just flew the FBW A320NEO, but now that the PMDG 737 came along, I set different profiles up for them and the helicopter.

And it seems you cannot adjust or change control parameters on the fly, so-to-speak. If you make a change you have to save and apply but you also have to exit the simulation and restart for the changes to take effect.

So there I was checking the power throttle axis - which all worked fine - but it did not work. Only when I exited the simulation and rebooted did I finally get the lever to actually work.

So that takes care of that!! Now - how about those floats?


1 Like