Governor not working today

Was working fine yesterday. Now when I try to take off, the revs immediately drop and I sink back to the ground.

I haven’t changed any settings. The governor is still selected in the Heli Manager. I have tried restarting everything, but no luck.

Have I missed something really obvious?!


Hi @Routemaster and welcome aboard.

If the airport that you are starting from is at altitude, you might find that you will need to pull the fuel mixture lever back until the revs return to the green zone.

At higher altitudes, where there is less oxygen in the air, the amount of fuel being used will also need to be reduced, via the mixture lever, to keep the engine operating at its best.

Please give that a try and let us know how you get on.



Yup, a quick adjustment to the mixture fixed it. Strange, because I haven’t needed to do this before (and I was only at Gatwick!)

Thanks for your very prompt response.

Have to say, this helicopter is superb. It is like getting a whole new game.

Gatwick? That is odd then, unless pollution levels in our beloved capital are far worse than they should be and have cut O2 levels accordingly. :slight_smile:

Gatwick, at 203ft, is pretty close to sea level, so a fully rich mixture should be fine.

I’ll give it a try when i can get onto my sim PC, but the only other thing that i can think of is that something else in your community folder is throwing it a curve-ball.

I can’t think how a ghost mapping might be messing it up, as the aircraft would normally follow the apparent settings of the virtual controls rather than where the physical controls might be positioned.

i’ll talk it over with the dev team and see if i might have missed something, but in the meantime, you at least have a workaround.

Maybe see what happens if you go to the esc menu and then resume. If that is dropping the mixture level back to 50%, that might be preventing your RPM from getting into the green. When you touch the physical control, even just slightly, the virtual lever should synchronise with the physical one and this might be what is fixing your issue. Moving it back further would still increase the RPM, but possibly not necessarily.

Then maybe re-try the flight and don’t use the ESC menu.

The ESC/Resume issue is one that MSFS introduced at its last major patch and one that will hopefully be fixed by Tuesday’s patch.

Funnily enough, the first time it happened I was in Tibet. So you may be right about the altitude. The strange thing was that when I closed MSFS and reloaded, it was still happening in Gatwick. Perhaps some setting that carried over…?

Anyway, thanks again. It is working now, that’s the main thing!

1 Like

I’ll make sure the devs are aware, so that they can check that out.

I’m afraid i don’t know enough about the inner workings of MSFS to say that such things might be carried forward when it is closed and reopened again, but I know a man who will. :wink:

Thanks for the heads up.