Heli Manager isn't working correctly

I load up heli-manager and then load MSFS. I select the '47 and airport and load in. When I select ‘FLY’ there is a graphic on the cockpit saying ‘Please run Heli Manager’. The Heli Manager is running and says 'Awaiting Aircraft.

I have restarted MSFS, Restarted Heli manager, edited the SimConnect.xml to SimConnect.xmlxxx in the LocalCache folder. Run both MSFS and Heli Manager as Administrator. Nothing is working for me.

I have noticed that when I have selected the ‘47 in MSFS the heli manager is showing the correct screen with the joystick setup etc, but when I press ‘FLY’ the heli manager flicks between pages a few times and then stays on the Awaiting aircraft’ screen.

1 Like

That does look like something on your machine is getting in the way of communication between the Heli Manager and the B47G in MSFS.

Maybe check your firewall/anti-virus logs/settings and perhaps the apparently now standard method of temporarily moving everything else out of the Community folder and seeing if that fixes it.

Perhaps it might also not hurt to restart windows before trying anything else.

1 Like

John are you still struggling with this ?

1 Like

we are trying to solve this topic …

so far the only way I found was to restart the machine to get back up and running, however I am not finding a constant, sometimes the error on the first flight restart or change of aerodrome and other times the error does not happen.

OK mate i’ll point Dan to this and see what we can find for you :wink:

Tony

For a while now, not just with the B47G, I have experienced something with MSFS that might have a similar cause. The aircraft loads up and occasionally the controls simply do not respond until i do a restart from the ESC menu. It isn’t exactly the same as the problem as stated in the OP, but there may still be a connection.

As it is a relatively quick workaround, to restart the flight, i have never got round to finding the cause and fixing it, but i strongly suspect that it is something to do with one or more of the mods in my Community folder. I have some time today, so I’ll see if i can make any progress, that might help. The challenge is going to be that the issue doesn’t occur every time a flight loads, so knowing i’ve fixed it might take a while.

I’ll report back with any progress.

1 Like

Hi Tony,
Sorry, not had much time to try until today. I’m still having problems. I loaded it up this morning and it worked for 1 flight. I landed, changed airport and then was hit with the same problem. I’ve tried disabling anti-virus and firewall but that hasn’t worked. I found my community folder but there is nothing in it. What do i need to do with it?

We’ll need to get to the bottom of your issue, but in the meantime and as a possible workaround, does restarting the flight, from the Esc menu, wake Heli Manager up?

I just rebooted my PC and loaded MSFS without loading HM (thought there is an icon in the tray showing it is running). I started a flight with the '47 and it worked fine, though I didn’t get the HM window showing at all. I landed and started another flight at a different airport and I got the in-cockpit ‘please run HM’ screen. It seems to work the first time after a reboot but stop working after the first flight evey time.
I made a video, just uploading it to youtube now. I’ll post a link when its uploaded.

Fix is in the works, hopefully today :slight_smile:

Tony

1 Like

Awesome. Glad you have found the problem, look forward to the patch.

Just FYI, Here is the video:

1 Like

There will be an update shortly, that should fix that one.

Once you have installed that, please let us know whether it has been solved.

Thanks

Update Incoming! - General Forum - FlyInside Helicopters Forum (flyinside-helis.com)

I hate to be the bringer of bad tidings but it actually seems worse now :frowning:

The first time I loaded MSFS after I installed the new HM it worked fine. I landed, changed airports and I was back to the same problem. I tried pressing the new button on HM but it didnt seem to do anything at all. I’ve shut down MSFS and HM, reloaded and still the problem. Also, I have tried rebooting (which previously allowed me to run it ok) but now that doesnt work either.

Sorry.

Sorry to hear that John! Could you shoot me an email, dan@flyinside-fsx.com ?

I’d like to setup an AnyDesk session so I can do some debugging and see why it still isn’t working for you.

Hi, I´ve the same problem now

Could you help me?