Heli Manager quitting?

So I have tried a couple of Xcountry flights and it seems that after about 1.5 hours up to 2.0 hours my Heli Manager is quitting and I also lose all of my controllers, needless to say it’s not a pretty ending.

When this happened last time I quickly paused the sim, checked to see if my sim still see’s and recognizes my controllers and it does everything seems fine except no control of my 206 and the Manager says it does not see the helicopter.

I let the 206 crash then load another aircraft and everything works fine. Has anybody done a straight through 2 hour flight and not have this happen?

I know this is probably very odd and not sure if it’s a Heli Manager thing or not but thought I would bring it up here first.

Thank you for the report, we’ve had a couple of reports on this now (all involving 1.5-3 hr flights). The team is working on fixing it, but it’s a bit tricky given the length of time to test/analyze.

Understand completely, thank you for your response.

I had this happen too, after about 2 hours. I landed, i think i Alt-Tabbed out to check something in discord, when i came back i had no controls. Heli Manager didnt crash, but said “you must load a flyinside helicopter” with a Try Again button. Clicking Try Again did not recognize it. Then i tried quitting heli manager, same result. I had to exit the flight and respawn in. I also checked msfs sensitivity page in control options, the controls were properly recognized there.

Just lost controls during a fairly long fight. Heli manager was working fine but all controls stopped responding and it just fell out of the sky. It was a min or so after my fuel warning light came on (started at 50% fuel) if that’s any indication as to how long into the flight it occurred.

First time I’ve experienced this, but am sure it’s the longest flight I’ve done in the 206.

It COULD have been fuel starvation :frowning: If not, we have had a very few people with the same kind of issue but have not been able to reproduce it. It’s a top priority for us.

Stay Tuned


1 Like

seems kind of quick to have a fuel warning light a min or two and then the engine dies, I thought it came on about 20 minutes before fuel starvation, but I very well could be wrong. In my instance that was def. not the issue sadly.

That’s strange, like I said though, not 100% sure it’s a Helimanager thing or not. I’m about to start the same flight with a different aircraft and see if I have the same thing happen again.

Yup, could be a complete red herring and probably is. I mentioned it more as for an estimate on how long i’d been flying.

So I just did the same flight plan (man that was a long flight 98 Gal 2.5 ish hours). I did this in another aircraft, no problems. Flyinside team, let me know if there is anything I can do to help to find/solve the issue.

Fix is due out tomorrow. If you Join our Discord server you could try the beta early.


Would love to, what should I Search for or can you send me an invite?



1 Like

Done, Thanks, Just joined now.

So far, so good with the 1.99 build. (2hr+ flight) Will test more this evening.

1 Like

Same here, 2+hours and no loss of control, However I did notice that I appeared to lose some sound over time with this update. Loss of Rotor Slap, loss of engine sound, It sounded like I still had the sounds of wind and Exhaust, so that is strange.

The loss of controls seems fixed and that is greatness, thanks for sticking with that.

This happened to me yesterday as well. The simulator had been running for quite some time but it was only a few minutes into a freshly loaded flight that heli manager crashed/shutdown.

Please make sure you are running the latest 1.99!!



Updated - I missed that before I posted, thanks!

Just when I was getting into this helicoptering. heli-Manager decides not to play ball…At all. Load sim, please run Heli-Manager and Heli-Manager doen not run. No matter how many clicks and swear words I use. I have tried reinstalling the B-47 in the hope that it would bring the manager to life…Nada. I have uninstalled everything Fkyinside including all those tucked away files. Reinstalled everything and heli-manager pops up as part of the install. Run sim, all is well. Enter registration serial for both aircraft. Have a flight. Shut down the sim and computer. Have dinner.
Come back after chicken cordon bleu (mmm) Go through the routine and I’m back to square one. No heli-manager. Shut down sim, PC, kick the dog and scream at the wife. Didn’t help
What the heck?