Magneto key turn difficulty with Oculus Touch controllers

With the Bell 47 for X-Plane, I’ve been practicing the start-up and shut-down procedures. I have not been successful in grasping the key hot spot properly to get it to turn to the various positions. It grabs. I feel the haptic vibration. I’ve tried turning the controller, sliding it right, left, up, down, in, out. I’ve clicking on the desired key position.

I can see, hear and feel the key turn, but it always snaps back to ON when I let go.

Am I trying to manipulate it incorrectly?
Am I out of sequence and it’s disallowed when I try to turn it?

Please advise.

Hi Dave,

That sounds like you might have another one of your physical controls mapped to the magneto switch and it is this mapping that is preventing it from moving from the position that your physical control is in.

Perhaps do a search for “magneto” in each of your physical controllers, to see if you can find any unwanted mappings.



Good thought, but not really possible. I only have 4 controls and they are all bound to what they are meant for: cyclic, pedals, collective and throttle. All switches, knobs, levers, etc. I use the game controllers to manipulate.

Have you checked that the sim hasn’t “guessed” at what mappings you might require for your controllers though?

Particularly when MSFS is updated, it can add mappings based on what it thinks each controller should be used for, so still worth checking that nothing odd has been introduced, if you haven’t already of course.

Just out of interest, can you adjust the magneto switch when in another aircraft, the default C152 for example?

Yes. The magnetos manipulate as expected in other aircraft.

You mention MSFS. I’m flying X-Plane, so doubt that bug you mention applies.

There really isn’t a “binding” or “mapping” for game controllers, I don’t think. I’m doing this in VR. You reach out and “touch” the hot spot manipulator provided by the aircraft developer (FlyInside). It is bound to whatever it is bound to. It’s part of the aircraft. You pull the trigger on the controller and rotate your wrist or move your hand side to side until the thing moves.

Maybe I’m misunderstanding. I may be able to provide a screenshot or maybe a video, if that would help.

Are you one of the FlyInside developers?

ah, sorry Dave, i had wrongly assumed that you were flying on MSFS, apparently missing your mention of XPlane in your OP.

I am not one of the developers, just a tester and long time user of the Bell 47. I’m also a mod on this forum.

As most of my flying is done within MSFS, I’ll load up the Bell from within XPlane and see if i can reproduce the issue you are seeing. I’ll get back when i’ve checked it out.



Right then, I’ve just given the Bell a try in XP11, using my now rather dated Oculus Rift and associated Touch controllers.

I can get the key to turn and remain in any of the positions, but it can be a little fiddly. I seem to have most success by pointing at the key, holding the trigger and dragging the control left or right until the key is in the desired position. The key does appear to remain in position when i let go of the trigger.

As a more frequent user of XP11, you might already know this, but if i am holding the trigger down before i move the pointer over the key, i have to let go of the trigger and press it again, before it will drag.

Maybe give it another try and if it still doesn’t work, I’ll have a word with the others and see if they’ve seen this behaviour before.



I fiddled some more with it. I was able to get the switch to each of the positions, but it took multiple tries to get it to stay there. It was very easy to knock it off the position when releasing the trigger. I found the the switch will swivel CCW and CW as the controller moves in and out perpendicular to the console. The most reliable technique for me was to flatten the controller against the console, point it and align it with the position I wanted, then click the trigger. The switch did not always come to that position.

At least now I can get it where I want it to do a start-up / shut-down sequence (which I’ve now done).

I still think that interaction can be much improved. A twist of the wrist would be the natural motion.

I did capture some VR video of me operating the switch, but this platform doesn’t accept video.

You mention “now dated Rift”. I’m curious what you’re using?

I still use an Oculus Rift CV1.

My original one had suffered the quite common fault with the right earpiece, just after the 2 year warranty period, but Oculus generously replaced it anyway. That replacement has now suffered the same fate, again after more than 2 years, so I’m now using the headset alongside a set of headphones, which isn’t a major issue.

I’ve been considering getting a Quest 2 or a G2 and now that GPU prices appear to be getting more sensible, that might be sooner rather than later.

Thanks. I’ve been happy with my Rift S. It’s a couple years old now. Running with nVidia GTX 1070. I’m also in the market for a new system, but I’m waiting for XP12. That HP G2 is high on my list. I have a Quest 2 and the resolution is just not up to snuff for what I want to do. I’m looking for VR hand tracking manipulation in the cockpit. Had it for a while WAY back with FlyInside and a Leap Motion sensor, but then XP got VR natively and that disappeared. I’d REALLY like FlyInside to put out a general controller emulator so we can use the various sim platforms using our hands.

I’m off topic here, but thanks for the reply.

Have you seen this, PointCTRL - Finger Mounted VR Controller - Page 121 - Input and Output - ED Forums (

It looks like they have yet to get it working with MSFS, but if they do, it looks like it will be a worthwhile addon.

I had not seen that one. I’ll watch it. Thanks.