New Update! FlyInside Bell 47 - Version 1.71

We’re excited to announce a major update (1.71) to the FlyInside Bell 47, released simultaneously for MSFS and X-Plane! We’ve enhanced the flight model to match improvements made to the the later version of the engine, and given it a fresh from the shop overhaul as well. You’ll have 220hp continuous available along with 240hp for 2-minutes maximum. This means better performance with a bit more MP available. Try it at high altitude!

Pay close attention to the engine temp gauges in your cockpit for overstress indications, along with charted limits. Placards are visible in the cockpit and also reprinted in the manual. Engine failures aren’t usually fun… unless you like to perform touchdown autorotations.

In addition you’ll find new static blade droop and dynamic blade coning effects for both simulators, Mac and Linux support for X-Plane, added X-Plane wind effects, and X-Plane Replay Mode support.

  • Adds dynamic and static blade droop and rotor coning effects
  • Flight model engine enhancements
  • Adds two-minute engine limitations and failures
  • Adds temp gauge indications of engine overstress
  • Updated cockpit placards
  • X-Plane Replay Mode now supported
  • Mac OS and Linux now supported in X-Plane
  • X-Plane wind effects now supported



Thanks for this great update.
The more horsepower make a new feeling of flight.
But still no floats :frowning:


Floats ARE in the wings so to speak, no exact date but soon hopefully :slight_smile:


1 Like

Thanks! I had my first engine failure in a long time. Didn’t see it coming. One thing that seems unchanged, though, is the pilot becoming invisible after take off from external cameras. So, in flight screenshots still need to be done from behind. Apart from that, nice work. It’s still by far my favorite aircraft in MSFS.

1 Like

Is that just with our 47 mate ? Or does it happen with all 2020 avatars/pilots in other Aircraft?


That’s just the 47. Here is how to reproduce the bug (if it’s one): start flying with the Bell, with cockpit camera. Activate Pause; switch to external or showcase: no pilot! It’s linked to pause. If you switch cameras without pausing, pilot shows ok, and stays there if you pause after switching cameras. But switching after pausing, not ok. I checked with a couple of random GA aircrafts (not addons), and the pilot shows after pausing (though I noticed that the cockpit might appear empty at first, and the pilot just pops in after a second).

Thanks mate, I’ll get Dan to take a look.


I like this helicopter! Great job! - However, after the latest update 1.71 I noticed that the color of the needle of the manifold instrument is black and therefore not readable. Furthermor it seems that the pilot suffers “parkinson”. In other words: the pilot trembles in the outside view. Am I alone with this issue?

1 Like

for me there a more needle black now

Could we get screenshots from those of you seeing black needles? Our team isn’t get them.

this one is the only that work for me

all other look like this

and i use at all my Paints a black Paneldome,basic was the Green one from MESH(has same Error now),i hate this white,all get this Error now,it change nothing when i remove them…

Manifold pressure needle seems fine here (update VIII). Works like a charm since the last sim update. A pleasure to fly. I absolutely love the new engine. Pilot display bug still here, however.

can you tell me were i find the Texture to change the needles?

as the “black needles” issue appears to be a problem that doesn’t apply consistently across all pilots, could the selected livery or even other mods in the community folder be at its root?

I’m not at my sim pc atm, so will need to do some experimenting for myself later.

i remove all my paints again,i found they cause this,a clean install from the Heli work.
there is a new change in textures,i do not know were,and at Moment i will not waste more Time to fix…i will use them as is,if someone has a fix,please share.
as i have no fix,i will also disable all my Paints at

That information is likely to be very useful Ralf.

I’ll make sure that the devs see this, as it looks like it should provide a good clue as to where the issue might lie.

Thank you


1 Like

maybee this?

right one is in maintexture and left the old in my paints ?

i have fix it for me,
was this Texture

1 Like

It’s been a couple weeks, still no update on Steam Marketplace. Assuming you sent new version to Steam. Should I ask them to update or will you? Version there is 1.47.0.

We sent the new version over as soon as it was ready. It takes a little longer to launch as we don’t have control over that process. I’ll post back here as soon as it goes live.