New update released 11th May

When installing an update, you may simply download and install over the previous version. There is no need to uninstall any prior versions first.

  • “End Flight” Popup no longer appears upon landing
  • Radios no longer die after flying for too long
  • Lights no longer die after flying for too long
  • Compass now displays magnetic heading rather than true
  • Wind now comes from proper direction for physics calculation
  • Fuel capacity updated to 61 gallons
  • Fixes giant CG out of warning error in MSFS
  • CG now affects cyclic input/has rotational effect
  • Radio/transponder now sync with MSFS, can be used with ATC
  • Various reliability improvements to HeliManager
  • Decreased fuel burn rates

Any problems let us know :slight_smile:



I’m not very good at abbreviations. Would you please explain CG?

CG: Center of Gravity

1 Like

Thank you! I should have known that.

I installed version 1.2 today and have been trying to fly, but the Engine Governor isn’t behaving the same way it was before.

Previously, I have it turned OFF in the manager, and I manually turn it ON (on the collective) after engine startup when I’m ready to fly. Later, after flying, I manually turn it OFF so it can idle for a while.

Now, even though I have rebooted the game and my PC several times, and I still have it set to OFF in the manager, it seems to be on all of the time. When I start the engine normally, the engine goes to full throttle, with manifold pressure far above redline. When I click the governor switch down, the revs stay up, but the pressure drops to idle (on the display).


Hi Peter,

Do you have a throttle axis bound (to Propeller Pitch Axis)? Depending upon a variety of factors, MSFS defaults to 100% prop pitch, so if you turn the gov off the RPMs can shoot up high instead of idling. I would try binding one, and giving it a wiggle to set throttle to idle.

We aren’t able to reproduce, so it may be a controls/bindings issue, or we may have an intermittent bug on our hands.


I will try that later tonight and get back to you.


EDIT: Later that same day . . . I mapped my second throttle axis to the Prop Pitch axis. It works as you suggested, i.e. I need to have it there now for jiggling-purposes, likely due to your now-closer link to MSFS data.

Thanks again for your quick reply.

“End Flight” Popup STILL appears upon landing.

I deleted it from the community folder and re-installed it to ensure updates, but that didn’t solve the problem.

Hmmm everytime or just a one off so far ? Can you confirm your version number for us please :slight_smile: and do have you bindings with alternator/battery switches set up on a peripheral or similar ? Or how us those set up?


When I synchronized the ALT/BAT switch on the honeycomb yoke with the switch in the sim, there was no pop-up the first time.
Thought I had solved the problem. However, when I take off from there and landed again, the pop-up appeared.

The version is 1.2. I am checking the version of the heli manager from the list of applications in Windows.
Is there any other way to check the version?

I have a Honeycomb Alpha and Bravo and have had issues with hidden bindings from them causing issues, there is threads on the 2020 forum here = Discussion: Update #4 ( - #973 by JackFlash108 - General Discussion - Microsoft Flight Simulator Forums and here =

Also to check the heli-manager right click the exe go to details and you can check the version number there.


Hi xavior09, I use the honeycomb yoke as well. Since latest build the landing popup has been fixed and I have had no issues since.

I always start from cold & dark and have also removed any bindings related to the magnetos, as the mag bindings don’t play nice with the electrics. I’m not entirely certain why this is the case but have seen some issues with it.

Try that and see if that works for you and check your bindings very careful, as Tony suggested. Ghost bindings is a very real issue.


Since I synchronized the BAT/ALT switch on the honeycomb yoke with the switch on the shim, the pop-up appears once yesterday, but when I tried it today, it didn’t appear anymore.

If it appears again, try to unassign the rocker switch this time.

1 Like