Pedal Problem: No yaw control with pedals

Hey guys…
Just downloaded and started with the 47 today.
I noticed something that really bothers me. Upon runup and lifting the pedals have absolutely no impact on the yaw rate. Giving full left pedal still makes the helicopter yawing right. The axis is bound correctly, I can also see the pedals move accordingly in VR.
Played with multiple settings but no change. I guess something wrong on my end since I had not noticed anyone else describing the issue.
Any help welcome.

Cheers, ROB

Hi @HueyRob and welcome aboard.

Helicopters “rudder” pedals are there, at least in part, to counter the right turning torque of the rotors spinning in the other direction, so the more oomph you give the throttle, the more left pedal you have to apply.

However, there should still be enough in the left pedal to at least compensate for the torque of a fully revved engine.

Might you be overdoing the RPM? If you can keep the RPM in the green zone, you should be able to counter the yaw with some left pedal.

Please let us know if you are using the governor or if you are controlling the throttle with a control axis.

Paul

Hi Paul,
either way. No difference when using governor or manual throttle. Lifting, yawing to the right. No matter what. Absolutely no impact of the anti torque pedals…
Oh and yes: I am well aware of using pedals in a helicopter :wink:

sorry about that. I should perhaps ask about experience before potentially “insulting” peeps. :slight_smile:

it is odd though. so the animation makes it look like the pedals are going full deflection yet you don’t feel any effect?

How have you got the Heli Manager Flight Model tab settings set?

Paul, no worries. Not feeling insulted at all :wink:
Well, I went through almost all possible settings. Even with settings on “EASY” no tail rotor control is possible in any ways.
One thing that came into my mind was that upon start I get the message that the parking brake is still applied. But I doubt that that can impact pedal funcitonality.

That parking brake message shouldn’t effect it no, but i guess it wouldn’t hurt to use the keyboard key(s) or control that you might have assigned to the brake, for other aircraft, just to see.

As for the Heli Manager settings, it was the stability settings that i was wondering about. Have you tried sliding both of the stability sliders all the way to the left and seeing if the higher stability might have been stopping you from yawing?

Never mind. I’ve just tried that and i can still yaw.

Sounds like another controller is sharing axis possibly ?

Tony

1 Like

hmmm, now that sounds plausible

do you have an xbox controller plugged in for example?

and it might also be worth checking that no AI assistance has been selected, as auto-rudder might make a mess of your manual controls

Hey all…
Just tried and double checked your thoughts.
Slider position has no impact on yaw. Only difference I noticed was seeing the chopper yawing to the right when lifting, when on “0” with no chance to counterreact the torque.

All MSFS settings on realistic, no assistance anywhere clicked.
No axis conflicts. FYI: I am using a full scale helicopter pit (based on a UH-1) with axis assigned accordingly.

Sorry for one more question, but just to confirm, you can see full deflection, left and right correspondingly, on the Rudder Axis command in the Controls Mapping screen, when you move your pedals fully left and then fully right?

If you are seeing that, then I am afraid that I am at a loss.

The good news is that Dan is going to take a look and i am sure he will help you to get to the bottom of this. No pressure Dan. :slight_smile:

Hello Paul,

thanks again for caring.
To answer your question: Yes. I see full movement of the pedals according to the assigned axis. Full left - full right - lesser pressure both sides just as it should be. But no respoinse at all along the yaw axis. No matter which setting I am using.
I cross checked with other aircraft. No issues there. I’m lost also.

Cheers, ROB

Dan will be posting later today, to try to get to the bottom of the issue and hopefully you will be up in the air an enjoying the 47G soon.

Paul

1 Like

Perhaps you applied auto-rudder without knowing?

Hello Stamflyer…
As mentioned above, no auto-rudder is activated.

Cheers

Hi Rob,

Generally this issue (you can see your pedal input working in the 3d model, but no yaw response), is caused by assists being turned on from the “Assists” screen. Given it sounds like you don’t have any, it’s pretty strange.

If you’re interested, shoot me an email dan@flyinside-fsx.com and we can schedule a remote desktop session so I can take a look at your config and see what’s going on.

Thanks,
Dan

Dan,

Mail shot. :wink:
THX

Hey @ all!
I made it! I installed the latest (yesterday) update and all works well now! I still have no clue what the issue was but I am very happy now.
Thanks @ all for trying helping me out…

Guys,… I’m off flying now! C U in the air ! :partying_face:

2 Likes

Hello HueyRob

I have the exact same problem. Pedals moving but no response to the helicopter. But I just bought the helicopter yesterday and there is no update to install. I got the version from inside of Microsoft flight simulator 2020 Marketplace.

Any advice?

Did you get this sorted ? Only just spotted your post :frowning:

Tony