The Bell 47 does not want to work on MSFS after recent update (

Good morning…I can’t get Bell 47 working on MSFS after the recent update, I uninstalled and reinstalled version 1.32 and it continued anyway, it didn’t work, what to do?


Could you please provide more detail about exactly how it behaves when you load or try to load a flight with the Bell.

For example, does MSFS CTD, does the engine not start or do the controls not work?

The more information you can provide the better the chance that the devs will be able to reproduce and identify the cause of the issue.



Good afternoon Paul,

Well, when updating MSFS in this new version, there was an alert of lack of space on the SSD where Win10 is installed, so I created a folder on a backup HD, and I directed the update download there.

That done, I opened the simulator (which is ok) but the Bell 47 does not work, it appears on the runway with the engine off, and the “FlyInside Heli Manager” does not activate, it orders the aircraft to restart, which, when restarted, does not start its engine ( the start button on the collective is also not clickable).

Interesting to say that other aircraft (fixed wing) and scenarios, work normally.

However, curiously, the other helicopter (freeware) HPG Airbus H-135 also did not work properly (fly, but the panel is off)…

Find a solution there, I can’t be without my “flying bubble”…



Thanks for that Tarcizio

The last time i experienced something like you describe in MSFS, particularly the unclickable controls, it was due to the flight loading with the developer mode pause activated. Just to check, if you don’t already have it enabled, when you get the behaviour you describe, could you please enable developer mode and then check the options menu to see if the pause option is active.

Either way, I’ll make sure the devs see your post, to see if they might spot the cause.



I’m also having problems since update 5. When I click on fly, the progress bar moves to 100%, then just stays there. Sometimes it crashes before then (just hangs). The only way I have got MSFS working since the update is by not running the heli manager and selecting a fixed wing (sorry). I’m using a Dell Aurora R7, with an i7 8700 and GTX 1080

Hi Graham and welcome aboard.

Following MSFS updates, clearing the cache is usually a good idea, so please give that a try, before trying again.

Also, it looks like Asobo might have done something to upset 3rd party liveries, so maybe try one of the standard Bell liveries, if you aren’t already.



You might want to try this too Tarcizio, as the cache might explain the apparent differences in your issue and Graham’s

It worked for me yesterday. Loading took about 10 minutes, but after that it worked as before.

I’ve had no problems. It took a long time to load the first time after the MSFS update, but normal after that.

I deleted my rolling cache before running msfs after the update.

What I have noticed, is that the 47g still has a bit of stutter in the game when flying it, but the other aircraft and airliners like the 747-800, which used to suck the life out of the game, now run as good, if not better the the bell47?

Would it be possible to take a look at the Bell47 coding for things that might be adding to stutter?

This is with 5900x and rtx 3080, 32igig ram

Cheers :slight_smile:

1 Like

i have test all my liverys,all work for me :+1:

1 Like

I’m still having the same problem I have checked that I have the latest version of heli manager installed and deleted the rolling cache. Still the progress bar before flight gets to 100% then nothing happens. The fps does not change on reaching 100% and I don’t think there is any change in either CPU or GPU usage.

@GrahamDavis @Tarcizio - Could you both shoot me an email ? I’d like to schedule a debugging session for next week and figure out why it isn’t working for you. Anyone else hitting this same thing please let me know in this thread.

@dogmanbird - Thanks for letting me know there. We’re looking into some performance improvements for this bird (poly count is still a bit high, along with material count and texture memory usage). Once that’s completed it should hopefully help with any stutter.


Thanks for the offer. I’ve got a busy schedule next week, but I’ll let you know if I have a free moment.

Thanks Dan, that would be great :slight_smile:

Hi Graham,

Have you tried temporarily renaming the UserCfg.opt file that resides in the main MSFS installation folder? It will generate a new one on next start of the sim if it doesn’t find the file.

This has got me out of a few pickles with strange msfs aircraft behaviour in the past.

Recently, I’ve noticed stutter for the first 15mins after initial load with all aircraft.

I too, at first assumed it was the Bell or external link to manager.

I’ve noticed there’s disk activity during this stutter stage.

just my 2pence. May well not be related.

OK, it’s all working now! :smiley:. It seems I just needed a bit more patience. It took its usual 5-10 minutes initialising (usual following an update that is), but when the progress bar reached the end, nothing happened, even after leaving it for several minutes (previously it was ready for flight as soon as the progress bar hit the end). Finally, I just put it in the background and got on with something else. After around 10 minutes following progress end it started. So now I know just to wait it out after the next update. If there is any bug, it’s just to do with the progress reporting.

The H135 has to be updated for the panel/etc. to work correctly. The last time I checked the latest version was build 430 (aka 1.4.1).