Throttle stopped working

All used to work well until I updated MSFS recently. I can lift the heli off the ground to several hundred meters, and then it drops slowly to the ground whatever throttle I apply.

I searched the forum and I have done the suggestion. Mine is the the standalone version. I have tried to change the binding of the Thrustmaster joystick throttle to throttle axis 1, MSFS Sensitivty for each axis to 0%, and the reactivity to 100%, but it still doesn’t work.

Any other way to solve this?

Very very strange. Since you went over the bindings, a suggestion, and a couple of questions:

  1. Could you make sure all Piloting Assists are turned off? These interfere with flight controls in weird ways, and often get turned back on by sim updates.
  2. Could you confirm whether the built-in Governor is turned on or off?
  3. Any possibility the engine is dying on you? If so the radio will indicate “ENG FAILURE”

That’s it! Turned Piloting Assists off and the problem is gone.
Can you specify which assist causes the problem? I am a newbie and I’d like to turn on other assists. I used to turn all of them on and it’s no problem.

The helicopter is unfortunately incompatible with the assists (I believe all of them) due to how the flight model works. If you want some flight-friendliness in the 47, I’d recommend turning on Easy or Medium from Heli Manager.

I get it’s annoying when going back and forth with other aircraft, but there isn’t a good work-around at the moment.

Not all of them. I haved tracked down to those that affect Manifold Pressure gauge, which is causing the loss of control of the helicopter. I will experiment turning some assists on.

1 Like