Throttle doesn't work with latest SU7 Beta

Hi, I installed the beta today (which fixed the VR Toolbar issue finally), but now the throttle of the Bell doesn’t work anymore. I checked a bunch of other planes and it’s only the Bell which has this issue :-/

Maybe this info is helpfull - there is an issue with the beta where thottle doesn’t work when the mouse is hovering over an open window or any dial/switch/control option in the cockpit.
So for every other plane I simply have to move the mouse to another position before my throttle works again.
Maybe the Bell is build in a different way than other planes and fs2020 sees the cockpit interior as one huge dial, breaking the throttle?

Hi Warrie,

We haven’t seen this issue (the helicopter’s been nicely flyable for us in 1.21.13.0). Do you mean the throttle binding (helicopter collective), or propeller pitch axis binding (helicopter throttle)?

First thing I would check is that you don’t have any Pilot Assists turned on. More info here:

Thanks,
Dan

Hi Dan, thanks for the fast reply. The throttle binding / collective doesn’t work for me. So when I start in the air, the Bell drops down to the ground. All other controls (rudders, flightstick etc) work fine.
I checked the assistense settings but I have it set on hard mode. Just to be sure I set them to medium, saved, set it on hard again, double checked that all assistance options are off and saved again.

Also to be sure it’s not a VR issue, since with the beta VR still has bugs as I described, I just tried it in flat mode but same result - throttle doesn’t work.

I will go back to the non-beta now and see if that fixes the issue so we can at least determine if it indeed is an issue with the beta. I’m using the Steam version btw.

Will post here after I tested this.

The good news is that going back to the non-beta immediately fixed the issue.
So it is the (Steam) beta. Is there anything else I can test to figure out the cause of this?

I went to the beta again and throttle then doesn’t work.
But i noticed I have a newer version running than you - 1.21.18.0.
Could you upgrade to the latest beta and check if you have the same issue as me then?

I have exactly the same issue with 1.21.18.0
Windows 11.

AND: My R44 (with AirlandFS) also the same problem…

Thanks all! Thought I was on the beta but I wasn’t. Installing now and will be loading it up. Hopefully a replication/fix soon :slight_smile:

At least I’m glad to hear it’s not some weird issue on my end. Hope you can fix this, the Bell is practically the only thing I fly with since I bought it :slight_smile:

I’m sure we will! There’s a simulation variable that’s being updated incorrectly based upon Throttle Axis. Hoping MS will have a fix, but we’re trying to find a work-around in the meantime.

2 Likes

Could anyone experiencing this issue give this build a test-flight? It should correct it!

https://cdn-east-us.flyinside-fsx.com/b47/b39/FlyInsideBell47G.exe

I installed it but unfortunately the throttle still doesn’t work.
But I bought the Marketplace version of the Bell. I installed your zipfile and noticed that the first time loading of the Bell didn’t take the 5 minutes it normally takes after installing or after switching to the Beta version of FS2020.
Could it be that I’m still using the marketplace version now even though I did install your zipfile?

Hi Warrie,

That’s definitely possible. I would try removing the Marketplace version and seeing if it still shows up.

Thanks,
Dan

If set Throttle 1 Axis instead of Throttle Axis, works well.

Did you have a chance to test out the build I linked? Should work without needing to change the binding.

I saw in Content manager that both the marketplace and this standalone version were installed. So I uninstalled both, reinstalled your testversion, loading took ages again and just when it was done loading and I was grabbing the throttle… I noticed I need to enter a licencekey in Helimanager, which I don’t have since i bought it in the Marketplace :-/

Yes, it works again :slight_smile: Great that you could fix this so fast.
Will the Marketplace version also be fixed so i can switch back to that one later?

Yes sir! Just takes us a little bit to get updates published but it’s on its way.

1 Like

also confirming the exe works on beta with no controls changes :+1:

Works fine with the new .exe (MSFS2020: latest beta test version).